shmups.system11.org

Shmups Forum
 
* FAQ    * Search
 * Register  * Login 
It is currently Fri Dec 04, 2020 11:35 pm View unanswered posts
View active topics



Post new topic Reply to topic  [ 16 posts ] 
Author Message
 Post subject: bvm fault - snapping sound and picture shakes every minute
PostPosted: Sat Nov 14, 2020 8:09 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
hi all

wanted to see if people here can venture a diagnosis for the following issue on a bvm-d20f1 model.

the monitor works normally, shows a nice picture and everything works as expected, except that every minute or so there's an audible snapping sound coming from the back of the monitor, with a simultaneous twitch of the whole picture.
then after a minute this will repeat again.

the snapping sound is audible but not incredibly loud or anything, probably lower than the snap you hear when degaussing.


here's a recording of the fault:

https://dl.dropbox.com/s/8lezyfgb24husos/bvm-snap.mov


any ideas as to what could be causing this will be very welcome.

thank you.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Sun Nov 15, 2020 12:23 am 


User avatar

Joined: 05 Nov 2019
Posts: 535
Location: Massachusetts, USA
Have not checked your video yet (no speakers accessible at the moment) but your description makes it most likely sound like a cold solder joint - easy fix, as long as you can track down the bad solder! Hopefully that is the case.
_________________
For CRTs, A/V gear, video games & more, be sure to check out my eBay!

Image


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Sun Nov 15, 2020 7:49 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
thank you!


Top
 Offline Profile  
 
 Post subject: bvm fault - snapping sound and picture shakes every minute
PostPosted: Sun Nov 22, 2020 7:54 am 


User avatar

Joined: 17 Jan 2016
Posts: 302
I have a little good news and quite a lot of bad news.

The good news I have had exactly this fault on a D24 back in the day and managed to repair it. It would crack intermittently and the screen would wobble when it did.

The bad news is that it was a faulty flyback. I had to use a spare one recovered from a dead old d24 which had a faulty tube.

You might struggle to locate this part but Savon Pat would be a good start. Also, changing this is INCREDIBLY dangerous if you don’t know what you are doing. You could seriously injure or kill yourself if you don’t discharge everything properly. You might want to find a professional to do this for you, but good luck finding an engineer still qualified or willing to work on a crt.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Mon Nov 23, 2020 10:46 am 



Joined: 26 Feb 2010
Posts: 415
Hello,

This is very likely a fault on your D20’s PA board. Do guy have a multimeter?

If you can, please PM me.

Thanks


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Mon Nov 23, 2020 11:07 am 


User avatar

Joined: 19 Feb 2017
Posts: 22
hello, thanks everyone for chiming in, had a friend look into this.

he checked and recapped the PA board, then fixed some cold solder joints in the flyback, and applied vaseline to the cap.
we thought the monitor was fixed because the fault was seemingly gone.
but as I found out later, it still has the same fault, it's just that instead of doing it every minute it does it every 15 minutes or so.

an improvement but not quite there yet.
my friend things the PA board wasn't related to the fault.

I have zero technical skill when it comes to electronics so I can't really give a more in depth update.

any ideas would be more than welcome.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Mon Nov 23, 2020 7:29 pm 



Joined: 26 Feb 2010
Posts: 415
One important thing: you should have dielectric grease applied to the anode cap. Vaseline isn’t a suitable replacement as far as I’m aware.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Tue Nov 24, 2020 9:23 am 


User avatar

Joined: 19 Feb 2017
Posts: 22
philexile wrote:
One important thing: you should have dielectric grease applied to the anode cap. Vaseline isn’t a suitable replacement as far as I’m aware.


will try to clean up the vaseline and apply this instead, thank you



is this the right stuff?

https://www.amazon.com/Permatex-81150-D ... 000AL2RI2/



should I wipe off the vaseline and clean any left overs with isopropyl alcohol?

(I understand you can only do this with a discharged tube)



thanks


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Tue Nov 24, 2020 12:56 pm 


User avatar

Joined: 09 Aug 2017
Posts: 1461
Location: Australia
Wipe it clean with a dry cloth, water or iso can dissolve the aquadag if you are not careful.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Tue Nov 24, 2020 1:44 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
Syntax wrote:
Wipe it clean with a dry cloth, water or iso can dissolve the aquadag if you are not careful.



thanks

is this the correct thing to replace the vaseline with?
https://www.amazon.com/Permatex-81150-D ... 000AL2RI2/


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Wed Nov 25, 2020 1:29 pm 



Joined: 17 Mar 2018
Posts: 126
Location: Germany
EDIT you already know that you should discharge the tube, moving on :oops:

https://www.youtube.com/watch?v=2YaElaoPTBk

This is a video related to the PA board and over loading. Does yours go into overload? Maybe you could try what happens if you crank up brightness on an all white screen.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Wed Nov 25, 2020 3:36 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
SuperSpongo wrote:
EDIT you already know that you should discharge the tube, moving on :oops:

https://www.youtube.com/watch?v=2YaElaoPTBk

This is a video related to the PA board and over loading. Does yours go into overload? Maybe you could try what happens if you crank up brightness on an all white screen.



yeah thanks I did watch that video, the overload indicator does light up occasionally when showing an overly bright picture, but never really shuts down like in the video.
I took this to be normal behaviour even after watching the video.

maybe I should put 25 ohm terminators? It's pretty bright but doesn't bloom in weird ways.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Wed Nov 25, 2020 8:39 pm 



Joined: 14 Oct 2016
Posts: 39
asasra wrote:
philexile wrote:


Yup, that one works!


Top
 Online Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Wed Nov 25, 2020 9:14 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
bahamutfan64 wrote:
asasra wrote:
philexile wrote:


Yup, that one works!



many thanks


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Thu Nov 26, 2020 12:16 am 


User avatar

Joined: 16 Jan 2014
Posts: 1056
asasra wrote:
hello, thanks everyone for chiming in, had a friend look into this.

he checked and recapped the PA board, then fixed some cold solder joints in the flyback,
an improvement but not quite there yet.


The flyback that was mentioned is a high voltage step up transformer, there are no solder joints in it. It must be replaced.


Top
 Offline Profile  
 
 Post subject: Re: bvm fault - snapping sound and picture shakes every minu
PostPosted: Thu Nov 26, 2020 10:32 pm 


User avatar

Joined: 19 Feb 2017
Posts: 22
Josh128 wrote:
asasra wrote:
hello, thanks everyone for chiming in, had a friend look into this.

he checked and recapped the PA board, then fixed some cold solder joints in the flyback,
an improvement but not quite there yet.


The flyback that was mentioned is a high voltage step up transformer, there are no solder joints in it. It must be replaced.



yeah I'm rereading the explanation and I got this wrong. the cold solder joints he fixed where not in the flyback, I got that jumbled up, sorry.

thanks everyone for chiming in, any ideas on what to look for is appreciated.

I've recorded a new video of the issue:
https://dl.dropbox.com/s/u8jgvchv9girol9/bvm-snap.mov 

There doesn't seem to be any sparks or anything, it's just that the screen twitches and there's a quiet snapping sound, about every 15 minutes.

Regards


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 

All times are UTC


Who is online

Users browsing this forum: bahamutfan64, frsj8112, ulihox and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Space Pilot 3K template by Jakob Persson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group