shmups.system11.org

Shmups Forum
 
* FAQ    * Search
 * Register  * Login 
It is currently Thu Jul 02, 2020 4:09 pm View unanswered posts
View active topics



Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Drifting purity problems on CRT, casued by bright elements
PostPosted: Fri Jun 26, 2020 7:04 am 


User avatar

Joined: 17 Apr 2008
Posts: 1669
So my Panasonic ct-27d20b, curved shadow mask with component made in 2000, has some pretty severe purity issues.

Basically, anywhere on the screen you have a bright object for a short period of time, the purity gets totally screwed, and it takes about a minute to return to normal.

I took some pics.

First picture shows a screen right after switching on, mostly correct, but has a purity issues in top left.

2nd and 3rd picture show how bright objects on right side will turn that side yellow

4th and 5th pictures show how bright objects on left side will turn that side magenta.

Last picture shows how bad the picture can get when the whole screen is white. Purity is basically only correct on the middle-right area of the screen

https://imgur.com/a/H6pm2c7

So what is happening here?

My two best guesses are that there is some magnetic interference between the yoke and electron gun or neck board. Or the actual shadow mask is getting magnetized by the electron beam.

Anybody seen this before?


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Fri Jun 26, 2020 11:39 am 


User avatar

Joined: 16 Jan 2014
Posts: 906
Probably a silly question, but did you try an external degaussing coil? Looks almost like the aperture grille has been magnetized.


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Fri Jun 26, 2020 4:28 pm 


User avatar

Joined: 17 Apr 2008
Posts: 1669
Yeah I'm going to buy a degaussing coil, because it will be nice to have one anyway even if it doesn't fix this CRT

But what's confusing me is how this purity issue "migrates" around the screen based on where bright elements are shown. Seems like purity issues are typically more static and don't change based on what you're showing on the screen


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Sat Jun 27, 2020 5:32 am 


User avatar

Joined: 24 Jul 2016
Posts: 275
I think i've seen this, but not to anywhere near the level it's happening here. One of my arcade setups has purity that wanders just slightly - i took it to be because it's a consumer tube that was never meant to be laid back at 45-degrees in a lowboy, so the yoke/purity (and to a lesser extent convergence) are sitting on "just ok" with no wriggle room, and things like bright patches on the screen can mess it up slightly. But the effect is so small i'm the only one that would notice. Degaussing doesn't change this effect though.

Do you get the same result if you rotate the tube 90-degrees on the flat, to face east rather than north or whatever?


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Sat Jun 27, 2020 9:44 pm 


User avatar

Joined: 17 Apr 2008
Posts: 1669
buttersoft wrote:
Do you get the same result if you rotate the tube 90-degrees on the flat, to face east rather than north or whatever?


Basically the same result, the bad spots just move around slightly. Like if I turn it 180 degrees, the magenta spot flips to the from the top corner to the bottom corner. And I power down before I turn it.


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Sun Jun 28, 2020 12:35 am 


User avatar

Joined: 25 Mar 2009
Posts: 249
Location: USA
Does it make the distinctive degauss "thunk" sound when you turn it on? if not, maybe the degauss thermistor has gone bad, or the solder joints have cracked.


Top
 Offline Profile  
 
 Post subject: Re: Drifting purity problems on CRT, casued by bright elemen
PostPosted: Sun Jun 28, 2020 3:30 am 


User avatar

Joined: 17 Apr 2008
Posts: 1669
I hear a noise, but it's not the heavy thunk. I thought it just has a quieter degaussing system, but maybe what I'm hearing is just other parts of the CRT switching on. I guess I'll take a look at the thermristor.


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: DarkAries, Google [Bot], grifter and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Space Pilot 3K template by Jakob Persson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group