shmups.system11.org

Shmups Forum
 
* FAQ    * Search
 * Register  * Login 
It is currently Sun Mar 24, 2019 8:27 pm View unanswered posts
View active topics



Post new topic Reply to topic  [ 395 posts ]  Go to page Previous  1 ... 10, 11, 12, 13, 14
Author Message
 Post subject: Re: NES/SNES 240p dejitter mod
PostPosted: Fri Mar 15, 2019 3:37 am 


User avatar

Joined: 02 Apr 2018
Posts: 41
Location: Arkansas
Today I experimented with injecting dejittered csync into the video encoder on a SNES Jr. Based on the how difficult it would be to lift the csync pin on the 1-chip, I decided to lift pin 7 on the S-RGB encoder and solder a wire directly from it to pin 15 of the CPLD on my dejitter board exactly like maxtherabbit's mod. I added a bit of electrical tape under pin 7 to make sure it stays isolated from the stock Csync pad. This is what my install looks like. Ignore the extra two wires on pins 12 and 17, those are for the S-Video mod.
Image

This install was done with my experimental RGB bypass + Dejitter board, but it should be functionally identical to the standard dejitter board.
Image

I tested this setup using an HD Retrovision SNES Component cable on my OSSC at line5x connected to my Epiphan AV.IO 4K HDMI capture device, which can't normally sync to 5x on a stock SNES. The HD Retrovision Cable uses composite video for sync so it's a perfect test cable for this mod. Below are some captured images from my testing.

Spoiler: show
Image

Spoiler: show
Image


Here is a capture of my setup with a normal C-Sync cable for comparison.
Spoiler: show
Image


I'm pretty happy with the results. I don't see any visual artifacts from the mod.
_________________
plus ça change,
plus c'est la même chose,
The more that things change,
The more they stay the same.- RUSH- Circumstances

Visit my modding store at arthrimus.com


Top
 Offline Profile  
 
 Post subject: Re: NES/SNES 240p dejitter mod
PostPosted: Wed Mar 20, 2019 11:35 am 


User avatar

Joined: 17 Jan 2016
Posts: 252
I have a problem with my nes install

I had my nes rgb from ebay, pre installed

I bought the dejitter from videogameperfection so it should be pre programmed for nes. I closed the jumpers as per the instructions on retromodwiki - it doesn’t reallly say why but I did what it says

I just get a black screen when powered up even on my crt.

I have rechecked everything and The only step I cannot be sure of is where it says

“You should also make sure that jumper J8 on the NESRGB is open (not pictured).”

It’s a shame it’s not pictured because I have looked at this thing for an hour and can’t find anything labelled j8

I have checked all continuity and there are no shorts

Any ideas what might be wrong?

Image

Thanks


Top
 Offline Profile  
 
 Post subject: Re: NES/SNES 240p dejitter mod
PostPosted: Wed Mar 20, 2019 1:50 pm 


User avatar

Joined: 21 May 2013
Posts: 148
LDigital wrote:
“You should also make sure that jumper J8 on the NESRGB is open (not pictured).”

It’s a shame it’s not pictured because I have looked at this thing for an hour and can’t find anything labelled j8

J8 is near the Green/Blue output pins, so on your picture you'll need to disconnect some of your Red/Green/Blue pin headers to see it.

All the NESRGB V1.4 jumper positions are shown on the "Pinout and jumper diagram" linked on the main NESRGB page:-
https://etim.net.au/nesrgb/NESRGB-Pinout.pdf


Top
 Offline Profile  
 
 Post subject: Re: NES/SNES 240p dejitter mod
PostPosted: Wed Mar 20, 2019 2:24 pm 


User avatar

Joined: 17 Jan 2016
Posts: 252
You beauty! That was the missing ingredient. Apparently it has to be TTL for the dejitter to work. Thanks so much


Top
 Offline Profile  
 
 Post subject: Re: NES/SNES 240p dejitter mod
PostPosted: Fri Mar 22, 2019 1:27 am 


User avatar

Joined: 05 Mar 2018
Posts: 544
marqs wrote:
sofakng wrote:
Would a sync stripper (Sync Strike) cause a picture shift?
I recall it uses a LM1881 so output sync is slightly delayed, causing picture to get shifted left a bit.

maxtherabbit wrote:
Upon further examination, I've discovered this console has jailbars. I don't remember seeing them before I did the mod, but then again I also didn't really scrutinize it prior to now. So my question: does anyone think that my placement of the dejitter board:
SHVC-CPU-01 is known for faint jailbar-like artefact so I doubt it's related to the mod. You could try adding extra ~10uF ceramic SMD cap near PPU2's 5V supply pins since apparently that has helped some people.

just wanted to update anyone following along, I followed this thread: https://shmups.system11.org/viewtopic.php?f=6&t=62631

and stacked 10uf ceramics on top of the existing decoupling caps for PPU1/2, CPU, WRAM, and both VRAM chips - now my noise issues are completely resolved - the upper deck dejitter mod is good to go!


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 395 posts ]  Go to page Previous  1 ... 10, 11, 12, 13, 14

All times are UTC


Who is online

Users browsing this forum: erik343, fernan1234, FinalBaton, samoeda, SNK-NEO-GEO and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Space Pilot 3K template by Jakob Persson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group