shmups.system11.org

Shmups Forum
 
* FAQ    * Search
 * Register  * Login 
It is currently Tue Aug 20, 2019 3:55 pm View unanswered posts
View active topics



Post new topic Reply to topic  [ 155 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Thu May 15, 2014 8:11 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Well, here I am with more glitch stories. This one is driving me nuts.

I have an NESRGB modded NES-101. I have two seperate N8s that I have tested on this thing.
On both carts, on some games I will get white dots popping up on the screen here and there. Kind of like the Magical Pop'n dots, but worse. One game that shows it pretty well is Raf World, on the first boss. The background is black, so you can see it quite well. I have noticed glitches like that in Kabuki, Raf World, and the JP versions of Metal Storm and Castlevania III. I'm sure it would show up in others, but that's what I've been focused on right now.

I was thinking maybe it was the NESRGB. Or maybe a conflict with the NESRGB and my CSY 2100, but it doesn't do this with my original carts.

Like with Kabuki, I will get those glitches going within 4 tries of taking the cart out and then putting it back in. Sometimes it does it the first time, but sometimes it takes up to 4. I tried the real cart 25 times, and never got one glitch.

I want to try a different cable, but the official cables I have are too wide to fit with the palette switch.

Anyone have problems like this? Or can give me some advice on troubleshooting? I'm a bit stumped.

UPDATE: Here is video of Jason from Game Tech, talking about the issue on my NES and EverDrive: https://www.youtube.com/watch?v=Hv0PaVG ... e=youtu.be
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Last edited by evil_ash_xero on Mon May 26, 2014 7:40 pm, edited 6 times in total.

Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Thu May 15, 2014 11:40 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Update: I was able to try another RGB cable, another power supply, two different CSYs, 4 different OS, and it's still the same.

No problems with normal carts, but the ED has problems. Both of them.

And it's not just when I start a ROM. It will have these white dots all over the menu sometimes as well. And I don't have to take the cart out, and put it back in to fix it. I can just push reset, and it can go away. Or it can be doing fine, and I push reset, and then I get white dots.

Frustrating as hell.

I keep thinking it's an Everdrive problem, but wouldn't some other people have these issues? I mean, I have two of them, from two completely different places. So, I doubt they are faulty.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 3:00 am 


User avatar

Joined: 21 Oct 2013
Posts: 688
I have a everdrive n8 and a powerpak, I'll check it out and let you know.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 3:47 am 


User avatar

Joined: 21 Oct 2013
Posts: 688
No issues with my everdrive n8, powerpak, or my real journey to silius cart.

https://www.dropbox.com/s/cw3nfeqqanfzzpu/raf.MKV


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 5:22 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Hmm....

Yeah, I'm not having this problem with my unmodded NES 101.

So strange that it doesn't have the problem with any other carts though.

Jason from Game Tech thinks it could possible be the reset button causing the issue.

Thanks again for having a look at yours, Pasky.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:21 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Here's a pic of the issue. In the background, Robert Smith disapproves.

Image
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Last edited by evil_ash_xero on Mon May 19, 2014 5:34 am, edited 1 time in total.

Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:27 pm 


User avatar

Joined: 21 Oct 2013
Posts: 688
Ya, that definitely doesn't happen with any of my carts. Including the N8. That may be bad ram actually, or maybe it doesn't like the latch.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:29 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Could you explain that a bit? Ram and latch?

Also, this happens with two different Everdrives. And no real carts do this on my NES. It's bizarre.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:37 pm 


User avatar

Joined: 21 Oct 2013
Posts: 688
The consoles IC's. I don't think it's bad ram, but it could be, looks more like the latch though. Some NES's have issues with flashcarts when using the slower speed latch (74LS) What does your PCB have? It'll either be a 74LS373 or 74HC373. If you have a 74LS373, try replacing it with a 74HC373 (order from digikey).


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:40 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Hmm...that's interesting. Didn't know anything about that.

Unfortunately, I don't know what I have in the PCB, and I don't have a modder at the moment.

I'm kinda stuck.

Any way I can find out what kind of latch mine has? I have ordered that screwdriver bit that opens NES systems. Is there something I should be looking for?
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 1:43 pm 


User avatar

Joined: 21 Oct 2013
Posts: 688
Only way to find out is open it and look at the IC. The good news is, the chip is only about a dollar.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 2:56 pm 


User avatar

Joined: 16 Sep 2011
Posts: 1150
Location: Germany
Check this video at 3:00 https://www.youtube.com/watch?v=Jog3EdUXOQI

Jason (is that his name?) point to the 74LS373 and says that you need to switch it to the HC version for a PowerPak, but not for the N8. But maybe the HC version will help you too with the N8.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 8:37 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Hmm...maybe that has something to do with it.

I wouldn't be able to change those chips. I can have a look at them though.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 8:45 pm 


User avatar

Joined: 06 Mar 2006
Posts: 11773
Location: Germany
Quote:
Jason (is that his name?) point to the 74LS373 and says that you need to switch it to the HC version for a PowerPak, but not for the N8. But maybe the HC version will help you too with the N8.

is this problem limited to NES2 models ? In the video he's using a classic Arcade PPU RGB mod. Moosmann has been using a AV Famicom (and a frontloader NES) with the Arcade PPU successfully with the Powerpak without any glitches.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 9:04 pm 


User avatar

Joined: 08 Oct 2013
Posts: 434
Location: Texas, USA
Fudoh wrote:
Quote:
Jason (is that his name?) point to the 74LS373 and says that you need to switch it to the HC version for a PowerPak, but not for the N8. But maybe the HC version will help you too with the N8.

is this problem limited to NES2 models ? In the video he's using a classic Arcade PPU RGB mod. Moosmann has been using a AV Famicom (and a frontloader NES) with the Arcade PPU successfully with the Powerpak without any glitches.


Don't think it was limited to the NES2, but it was an incompatibility with PC10 PPU in the old style rgb mod.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Fri May 16, 2014 9:10 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
For the record, my NESRGB is at 1.3 at this point.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Wed May 21, 2014 4:57 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Here's a vid of Jason from Game Tech testing it out.

I'd have to think SOMEONE would have a more recent batch of ED, and would have seen this problem.

Take a look. If anyone can chime in, that'd be great.

https://www.youtube.com/watch?v=Hv0PaVG ... e=youtu.be
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches
PostPosted: Wed May 21, 2014 6:09 am 



Joined: 17 Sep 2012
Posts: 395
evil_ash_xero wrote:
Here's a vid of Jason from Game Tech testing it out.

I'd have to think SOMEONE would have a more recent batch of ED, and would have seen this problem.

Take a look. If anyone can chime in, that'd be great.

https://www.youtube.com/watch?v=Hv0PaVG ... e=youtu.be


Looking at that video my Everdrive was built after yours (Adate: 16.12.13) but, mine is the Famicom version not the NES version. I don't see this issue on my Sharp Twin Famicom.


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches *now with vid
PostPosted: Wed May 21, 2014 7:13 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
OK, that's a good place to start.

Anyone here who has a cpld ver 2, and it works fine with your NESRGB, please chime in.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches *now with vid
PostPosted: Wed May 21, 2014 7:26 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
Also, I seem to get the vibe this particular NES, does not like EverDrives(well, it likes Jason's older one, it seems).
Both EverDrives work fine on my unmodded NES. However, normal carts do not have this kind of activity on this NESRGB modded NES.

What can be the cause of a system not working well with an EverDrive?
Would it be likely it's the system or the NESRGB?
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: Help with troubleshooting some N8 glitches *now with vid
PostPosted: Sun May 25, 2014 9:08 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
I'm gonna bump this thread, to see if anyone has come up with some ideas.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Sat May 31, 2014 4:26 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
So, nothin'?

Depressing. :(
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Sat May 31, 2014 6:59 am 


User avatar

Joined: 17 May 2009
Posts: 105
Location: California
Surely swapping that one TTL is easier than installing the NESRGB. It certainly can't hurt.

How is your NESRGB being powered? Did you do the regulator swap?


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Sat May 31, 2014 7:15 am 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
I had mine installed by Game Tech, so however he does it.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Sat May 31, 2014 11:17 am 


User avatar

Joined: 29 Jul 2008
Posts: 35
Location: Transylvania
I have an AV Fami with the Playchoice PPU and 74HC373 installed. I'd test for you but I don't have a PowerPak. If you want me to test with your PowerPak, happy to do so, send me a PM and we can discuss.

FWIW, most Japanese modders install the 74HC373 with the Playchoice PPU specifically for PowerPak use, so you may just want to have someone replace the chip for you. Anyone handy with a soldering iron can do it, I doubt it'll cost much. It's, what, 20 pins? :P


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Thu Jun 12, 2014 3:04 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
I have an update. Unfortunately, it's not a good one.

It seemed that the system had been fixed, if you've been keeping up with Jason's vids.
However, I got the system in today, and got the dots back, almost immediately.

I give up.

Image
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Thu Jun 12, 2014 8:36 pm 


User avatar

Joined: 22 Jun 2011
Posts: 1314
Location: Bedfordshire, England.
Well i have 4 NTSC Frontloader NES system here at the moment all fitted with the NESRGB and using a N8 Flashcart and havent come across this at all.

Are you using just the NES internal regulator or the NESRGB regulator as well as the internal one?


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Thu Jun 12, 2014 9:09 pm 


User avatar

Joined: 21 Oct 2013
Posts: 688
Get your money back.


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Thu Jun 12, 2014 10:26 pm 


User avatar

Joined: 12 Jul 2007
Posts: 5637
Location: Where the fish lives, WV
lettuce wrote:
Well i have 4 NTSC Frontloader NES system here at the moment all fitted with the NESRGB and using a N8 Flashcart and havent come across this at all.

Are you using just the NES internal regulator or the NESRGB regulator as well as the internal one?



I think Jason uses a different one than the stock one, but doesn't use the one that comes with the NESRGB. I think.
_________________
My Collection: http://www.rfgeneration.com/cgi-bin/col ... Collection


Top
 Offline Profile  
 
 Post subject: Re: N8 EverDrive Vs. NESRGB (glitches) *now with video*
PostPosted: Fri Jun 13, 2014 2:28 am 



Joined: 13 Mar 2011
Posts: 1042
Location: Toronto, Canada
Been following Jason on YouTube. This problem is isolated to your setup. Noise is being introduced somewhere. I don't believe it's the everdrive. I think Jason did a hell of a job proving that he went above and beyond any installer on this. Short of him sending you his PSU and CRT not sure you can do much more. Sorry to hear about your problems.

Can you try a different power supply, TV or extension cord / power bar?


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 155 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next

All times are UTC


Who is online

Users browsing this forum: Nuck-TH and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Space Pilot 3K template by Jakob Persson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group